Local HADDOCK results

Does haddock generate any log file reporting errors?
My job ran without any errors as far as I can tell. However, I did not get any output files. Please refer to the text for outputs of ‘ls’ command in different output folders.

$ cd it1
$ ls
ambig.tbl analysis iteration.cns unambig.tbl water
$ ls water/
analysis iteration.cns
$ ls analysis/
iteration.cns

Can someone guide me regarding what is happening?

Thanks a lot…

It clearly did not run since nothing was generated…

How did you run it? Did you redirect the output to some file?

What does it say?

Thanks for the suggestion. I reran it and redirected the output to a log file. It says the following:

HADDOCK cannot continue due to failed structures in it0
The following structures could not be docked.

I have made a single amino acid PDB from a peptide that binds to protein X. I am docking the single amino acid into the peptide binding site of protein X. Can you suggest a reason the docking fails?

I had previously tested the server to check if it can dock single amino acids. However, now I am running the local version. Is local version not meant to handle single amino acids?

Thanks a lot.

If the server can do it the local version can do it too :slight_smile:

But it’s all about your input data and settings.
Check an it0 output file and look for error messages, starting at the bottom of the file

Thank you for your response.

I tried a test job on the local server (haddock version 2.0) again and got the following error message -

Traceback (most recent call last):
File “/cluster/apps/x86_64/packages/haddock2.0/Haddock/RunHaddock.py”, line 425, in ?
run[‘haddock_dir’], run)
File “/home/gfuentes/software/haddock2.0/Haddock/Main/MHaddock.py”, line 284, in ForAllIterations
File “/home/gfuentes/software/haddock2.0/Haddock/Analysis/Diagnostic.py”, line 146, in GetDiagnose
UnboundLocalError: local variable ‘ret’ referenced before assignment

Is there anywhere I can find out more about this error? I don’t understand what it means.
Thank you.

P.S. If I run the same docking on my local PC with haddock2.2 it runs without any issues.

What is this local server? (haddock version 2.0)

Please use version 2.2 - we don’t support anymore 2.0.

Sorry for being unclear. It’s just a job submission server set up in our institute. They have the older version of haddock installed.

Thanks for your response.

Is it possible to use Haddock2.2 with cns1.2?
I am getting the following error in generate_B.out file when I use haddock2.2 and cns1.2:

Program version= 1.2 File version= 1.3
%MISCOM error encountered: Version numbers do not match - aborting program.
(CNS is in mode: SET ABORT=NORMal END)

Can you provide more details about what the error means?
Thank you.

You do need cns1.3 and will have to recompile it using additional code provided with haddock2.2 (see the cns1.3 dir in the haddock distribution).

Thanks again. Installation was successful and I cold run the docking.
Now, I have a query regarding the analysis.

After docking finishes, I get a cluster.out file in it1/water/analysis which looks something like this :
Cluster 1 -> 6 2 4 9 199
Cluster 2 -> 16 3 5 7 8 13 17

Where do I find the corresponding PDB files?

  1. Does *fit_6.pdb in it1/water/analysis correspond to the top ranked structure in cluster1 (cluster 1 -> 6)?
  2. Or it’s the *_6w.pdb structure in it1/water directory?
    Or I need to run some more analysis?

Thank you.

Where do I find the corresponding PDB files?

  1. Does *fit_6.pdb in it1/water/analysis correspond to the top ranked structure in cluster1 (cluster 1 -> 6)?

The number in the clustering file correspond to the rank in the water directory (check file.nam in the water dir to figure out which structure is at rank 6).

That number directly corresponds to the *fit_X.pdb number in the analysis directory