Local HADDOCK3 errors


I have installed HADDOCK 3 locally, and I have some questions about the [libutil ERROR].
I got this error:RuntimeError: 100.00% of output was not generated for this module and tolerance was set to 0.00%.

From the discussions I found on Github, it sounds to me that the issue is coming from CNS.
However, I am pretty sure I installed the CNS correctly, so I am wondering what could be the issue.
(I have installed the cns software following the instructions here: [haddock3/CNS.md at main · haddocking/haddock3 · GitHub])

In my cfg file, I have also defined:
cns_exec = “~/haddock3/bin/cns” (This path is linked to the executable in cns_solve_1.3)

Could you please let me know how I can try to identify the problem? Thank you!!

Below is the full log file:
Traceback (most recent call last):
File “/haddock3/src/haddock/libs/libutil.py”, line 310, in log_error_and_exit
File “
/haddock3/src/haddock/clis/cli.py”, line 178, in main
File “/haddock3/src/haddock/libs/libworkflow.py”, line 38, in run
File “
/haddock3/src/haddock/libs/libworkflow.py”, line 140, in execute
File “/haddock3/src/haddock/modules/base_cns_module.py”, line 59, in run
File “
/haddock3/src/haddock/modules/topology/topoaa/init.py”, line 250, in _run
File “/haddock3/src/haddock/modules/init.py”, line 269, in export_output_models
File “
/haddock3/src/haddock/modules/init.py”, line 278, in finish_with_error
raise RuntimeError(reason)
RuntimeError: 100.00% of output was not generated for this module and tolerance was set to 0.00%.
[2023-05-17 16:08:59,665 libutil ERROR] 100.00% of output was not generated for this module and tolerance was set to 0.00%.
[2023-05-17 16:08:59,665 libutil ERROR] An error has occurred, see log file. And contact the developers if needed.
[2023-05-17 16:08:59,665 libutil INFO] Finished at 17/05/2023 16:08:59. For any help contact us at Issues · haddocking/haddock3 · GitHub. At logo! Adu-siau! Good bye!.

First thing to check is if your CNS executable works fine.

Try simply calling from the terminal the cns exec you defined in the bin directory.
if it starts correctly you should see something like:

Thank you for the response!

I tried executing “~/haddock3/bin/cns”, and it works.
I got the following:

      |                                                          |
      |            Crystallography & NMR System (CNS)            |
      |                         CNSsolve                         |
      |                                                          |
       Version: 1.3
       Status: General release
       Written by: A.T.Brunger, P.D.Adams, G.M.Clore, W.L.DeLano,
                   P.Gros, R.W.Grosse-Kunstleve,J.-S.Jiang,J.M.Krahn,
                   J.Kuszewski, M.Nilges, N.S.Pannu, R.J.Read,
                   L.M.Rice, G.F.Schroeder, T.Simonson, G.L.Warren.
       Copyright (c) 1997-2010 Yale University

Nest step is then to search for error messages in the out files of the 0_topoaa directory


My out files from the 0_topoaa directory have the following error:

%AUTOAN error encountered: exceeded MXRTT (RTF) parameter → recompile program
(CNS is in mode: SET ABORT=NORMal END)

ABORT mode will terminate program execution.

Did you recompile cns with the provided cns routines?

I didn’t because I was getting some errors when I tried to install using the instructions in the haddock guide, so I just followed the instructions on the cns website.

Now I am trying to reinstall CNS following the haddock guide

Currently, I modified the path of CNS_SOLVE in both .cns_solve_env_sh and cns_solve_env
It seems like the software is executing cns_solve_env even though my system is in bash.
(Reason is that if I only modify the path in .cns_solve_env_sh, it gives the errors:
“environmental variable $CNS_SOLVE has been defined incorrectly
this variable is set in cns_solve_env - modify this file”)

So after modifying the path in both .cns_solve_env_sh and cns_solve_env, when I do make install in 3. Compile CNS in the instruction,
it gave me a lot of errors like: " Error: Type mismatch in argument ‘deriv’ at (1); passed INTEGER(8) to REAL(8)".

Any suggestions are appreciated!

Check the instructions at: https://www.bonvinlab.org/haddock3/CNS.html#5-Check-installation

Important is to change the content of the Makefile (and use gfortran) (read the Makefile section in the above link)

That works. Thank you so much!