Command not found HADDOCK binding site screening tutorial

I currently am trying to follow the tutorial " HADDOCK small molecule binding site screening" with my own protein-ligand docking run. I get to the step where am I going to run the following command using tcsh shell:

$WDIR/encode-contacts.csh structures/it0/Acontacts.lis AcrB_contacts.pdb

However, when I run it I instead get the following message:
/home/leo/HADDOCK-binding-sites-tutorial/ana_scripts/zone_b: Command not found

I´ve been inside the ana_script directory and run the commands “make” and “source setup.csh” which both were successful and I´ve also performed chmod + x Zone_b. Still, I get the same error message.

This has been posted before in this forum (Error when running $WDIR/encode-contacts.csh structures/it0/Acontacts.lis AcrB_contacts.pdb) but noone of the suggested solutions in that thread worked for me

Could anyone possible help me out?

Sorry for the naive question but does this path exist in your system? /home/leo/HADDOCK-binding-sites-tutorial/ana_scripts/zone_b

There are two executables provided for zone_b, one for Linux, one for MacOSX.

On which system are you running?

You might also try to install our PDB-tools (see ) and use those (modifying the scripts or writing your own).

We also have now a beta version of a PDB-tools web server available at:

I am really inexperienced with code so I dont know how to modifiy or create scripts. I am using a linux operative system atm. It would be really nice if this worked since I think it is a really cool application.

No, not that particular PATH. But the WDIR is coupled to ana_scripts since I sourced the setup.csh

Test if the linux executable is working. If it is create the proper link

Probably time to invest in learning more of linux and scripting - there is no free lunch :slight_smile:

A good starting point is for example the tutorials from

1 Like

I am currently doing my bachelor thesis and have limited amount of time. I do want to learn the coding aspect more later but now I am in a need of help.

Didn´t I already create the proper link when I sourced setup.csh? How do I test if the linux executible is working?

Well - probably the best in this case is to find someone around you with some Linux expertise.

Okey, thank you for your answer.