Error when running $WDIR/encode-contacts.csh structures/it0/Acontacts.lis AcrB_contacts.pdb

I already create the AcrB_contacts.pdb according to small molecule binding site tutorial using cygwin under tcsh shell, and when i trying to encode contacts into the b-factor column of PDB file using the following command:

$WDIR/encode-contacts.csh structures/it0/Acontacts.lis AcrB_contacts.pdb

i encounter the following error:

/ana_script/zone_b command not found.


However, when i checked the program zone_b F file is in the ana_scripts directory.

Would appreciate if anyone could reply and explain to me how to solve this. Thank you.

Try to compile zone_b.f in the ana_script directory. We are only providing Linus and MacOSX executables…

I checked the zone_b F file and I just want to confirm, is it written using old-style fortran? I am a beginner in programming language.

And i try to compile the zone_b.f file using gfortran under cygwin but it comes with following error.

And when i try to compile with g77 compiler under DOS, it show another error.

Would appreciate if anyone can kindly explain. Thank you.

Currently, i am trying to run the code under Ubuntu but still having same error. zone_b not found even when the zone_b executable is in the directory. Please help as i have try a lot.



Sorry for those naive questions but they might help to narrow down the potential issues you’ve encountered:

  1. Did you try to run the script directly? Something like:
    $ANA_DIR/zone_b -50 -zA2,A2 test.pdb (This assumes that you have a chain A with a residue id 2 in your PDB).
    It should assign the value 50 in the B-factor column of resid 2 of chain A in your test.pdb (it willl output it directly)
  2. Out of curiosity, scripts are all executable? (chmod a+x zone_b to allow for execution)

Thanks in advance,


The scripts are meant to run under tcsh or csh

Did you source the setup.csh script as instructed?

Yes, i am doing it under tcsh for source setup.csh

May i ask what language does the zone_b.linux used. As it is not view able when i open it.

  1. I run the script zone_b -50 -zA2,A2 3AOD-renumbered.pdb. It show zone_b command not found as well. 3AOD-renumbered.pdb is the default pdb come with the tutorial with chain A and residue id 2.

  2. i run the chmod a+x zone_b. The command doest produce any error and statement. I check the properties of zone_b, the file is executable.

Would appreciate if can kindly explain.

Did you try calling zone_b with the full path to it?

Did you source the setup.csh script as instructed?

zone_b.linux is a statically compiled fortran executable.