Challenges in Installing biobb_dna on Ubuntu: Seeking Solutions

Hello, I am writing about biobb_dna. Unfortunately, I am not able to install it on Ubuntu with pip and Anaconda. I encountered the following error with both pip as an example. Does anybody have the same problem, or does anybody know how to solve it?
note: This error originates from a subprocess, and is likely not a problem with pip.
error: metadata-generation-failed
× Encountered error while generating package metadata.
╰─> See above for output.
note: This is an issue with the package mentioned above, not pip.
hint: See above for details.

Hi, which version of biobb_dna are you using? Are you trying to install biobb_dna in a new environment?

I recommend to create a new conda environment instead of installing biobb_dna in an existing one. Try this:

  1. Create an environment.yml file:
name: biobb_dna_env
  - conda-forge
  - bioconda
  - biobb_dna==4.1.0
  1. Create environment from the above file:
conda env create -f environment.yml

Let me know if this worked for you.


thank you so much for your reply. I used this biobb_dna
do you think the problem is conda?i also need to install it in a supercomputer.

unfortunately I got the error after running conda env create -f environment.yml

  • conda-forge - bioconda
  • conda-forge
  • defaults
    Platform: linux-64
    Collecting package metadata (repodata.json): failed

UnavailableInvalidChannel: HTTP 404 NOT FOUND for channel conda-forge - bioconda < - bioconda>

The channel is not accessible or is invalid.

Hi, are you able to download packages in the computer where you are trying to execute it? Several supercomputers don’t have internet connection and it seems that this is the problem. Or maybe for some reason there are some adresses banned from this computer?

Have you tried in your PC or in a supercomputer? Have you installed other conda packages in your computer with no problem?


Hello, I tried to installed in my PC and I was unsuccessful. I can install other packaged with conda. but I cannot install biobb_dna with conda and pip.

Hi, I still don’t understand why you are using pip. The process of installation is only with conda following the steps of my first answer.


Hello, could you install it with conda? i followed the steps but I could not install it.

Hi, of course I can install it. Using the environment.yml file I provided you last week:

name: biobb_dna_env                                                                                                                                   
  - conda-forge
  - bioconda
  - biobb_dna==4.1.0

And executing the following instruction (it takes less than 2 minutes):

$ conda env create -f environment.yml
Retrieving notices: ...working... done
 - conda-forge
 - bioconda
 - defaults
Platform: osx-64
Collecting package metadata (repodata.json): done
Solving environment: done

Downloading and Extracting Packages
Preparing transaction: done                                                                                                                           
Verifying transaction: done                                                                                                                           
Executing transaction: done                                                                                                                           
# To activate this environment, use                                                                                                                   
#     $ conda activate biobb_dna_env                                                                                                                  
# To deactivate an active environment, use                                                                                                            
#     $ conda deactivate                                                                                                                              
(base) $ conda activate biobb_dna_env                                                                                              
(biobb_dna_env) $ conda list | grep biobb
# packages in environment at /path/to/miniconda3/envs/biobb_dna_env:                                                                           
biobb_common              4.1.0              pyhdfd78af_1    bioconda                                                                                 
biobb_dna                 4.1.0              pyhdfd78af_0    bioconda 

My conda info:

$ conda info

     active environment : biobb_dna_env
    active env location : /path/to/miniconda3/envs/biobb_dna_env
            shell level : 2
       user config file : /path/to/.condarc
 populated config files : /path/to/miniconda3/.condarc
          conda version : 23.5.2
    conda-build version : not installed
         python version :
       virtual packages : __archspec=1=x86_64
       base environment : /path/to/miniconda3  (writable)
      conda av data dir : /path/to/miniconda3/etc/conda
  conda av metadata url : None
           channel URLs :
          package cache : /path/to/miniconda3/pkgs
       envs directories : /path/to/miniconda3/envs
               platform : osx-64
             user-agent : conda/23.5.2 requests/2.29.0 CPython/3.11.4 Darwin/21.5.0 OSX/10.16 solver/libmamba conda-libmamba-solver/23.5.0 libmambapy/1.4.1
                UID:GID : 1147421021:1791188573
             netrc file : None
           offline mode : False

Note that I’m running it in mac, but it works as well in Ubuntu 16+.

Check that your conda version is updated.