Problem with Haddock 2.4 local installation

Dear users and developpers,
I am trying to install the version 2.4 but I have the following error:

HADDOCK version: 2.4 - June 2020 release
Python version: 2.7.17 (default, Apr 15 2020, 17:20:14)
[GCC 7.5.0]
PYTHONPATH system variable contains:
[’/work/programs/HADDOCK2.4/Haddock’, ‘/work/programs/amber18/lib/python2.7/site-packages’, ‘/work/programs/HADDOCK2.2’, ‘/work/programs/HADDOCK2.4’, ‘/work/programs/amber18/lib/python2.7/site-packages/ParmEd-3.2.0-py2.7-linux-x86_64.egg’, ‘/work/programs/amber18/lib/python2.7/site-packages/pytraj-2.0.5-py2.7-linux-x86_64.egg’, ‘/work/programs/amber18/lib/python2.7/site-packages/pdb4amber-1.7.dev0-py2.7.egg’, ‘/usr/lib/python2.7’, ‘/usr/lib/python2.7/plat-x86_64-linux-gnu’, ‘/usr/lib/python2.7/lib-tk’, ‘/usr/lib/python2.7/lib-old’, ‘/usr/lib/python2.7/lib-dynload’, ‘/home/muso/.local/lib/python2.7/site-packages’, ‘/usr/local/lib/python2.7/dist-packages’, ‘/usr/lib/python2.7/dist-packages’, ‘/usr/lib/python2.7/dist-packages/gtk-2.0’, ‘/usr/lib/python2.7/dist-packages/wx-3.0-gtk3’]
Traceback (most recent call last):
File “/work/programs/HADDOCK2.4/Haddock/”, line 100, in
newparsed = InputFileParser.ParseRunParam()
AttributeError: ‘module’ object has no attribute ‘ParseRunParam’

Any suggestion?

Which command gave that error?

Did you create run.param?

Check the provided examples

The command was just “haddock2.4”
I was trying the classical “protein-protein” example
This is the run.param file:


Did you source the before running the command? Could you check if all the paths are correct?

Also, please share the output of the following commands:

$ which python

Yes, I sourced the ‘haddock_configure.csh’ and all the paths are correct.

The output of ‘which python’ is:

The output of ‘echo $PYTHONPATH’ is:

Solved: I remove the python path for Haddock 2.2 and now it works. Thanks for your help.

1 Like

Thanks for sharing the solution! :slight_smile:

hello , honoratorv , I have the same difficuties with haddock . I have output the commands and this is the run.param file

HADDOCK version: 2.4 - May 2021 release
Python version: 2.7.17 (default, Feb 27 2021, 15:10:58)
[GCC 7.5.0]
reading parameters from the file ./run.param
setting some variables:
N_COMP set to: 2
RUN_NUMBER set to: 1
HADDOCK_DIR set to: …/…
PROT_SEGID_2 set to: E
PROT_SEGID_1 set to: B
PDB_FILE1 set to: ./anas_platyrhynchos_B_.pdb
PDB_FILE2 set to: ./anas_platyrhynchos_E_.pdb
PROJECT_DIR set to: ./run1
Traceback (most recent call last):
File “/home/yjx/software/haddock2.4-2021-05/Haddock/”, line 95, in
newparsed = {InputFileParser.ParseRunParam()}
TypeError: unhashable type: ‘dict’

which python



PATHONPATH: Undefined variable.

what should I do to deal with the problem ?

I have deal with the problem ,