Install haddock2.4

Hi everyone,

I downloaded Haddock2.4, and I am trying the installation as suggested in the haddock manual

I changed the config.local file to specify the location of my cns executable.

However, when I try to run the install.csh with the config .local I get the following error:

Setting up QueueSubmit to
POSTPROCESS: Undefined variable.

Can someone help me?

Hi Simonbis

Which version of HADDOCK2.4 do you have?
If the July release, simply try downloading it again.
There was an issue with the install.csh script

Dear Prof. Bonvin,

Thanks for your prompt reply.
As you suggested, I downloaded the most recent version of Haddock2.4 and the installation worked fine.

I tried to run some of the tests included in the Haddock2.4 package (e.g. haddock2.4-2020-07/tests/protein-protein, haddock2.4-2020-07/tests/protein-ligand, haddock2.4-2020-07/tests/protein-dna). In all cases Haddock is able to generate the run1 folder with the run.cns file. I did not change anything in the run.cns file and I just I run again haddock2.4. I got this error:
Error in the topology generation: prot_psf_mol1 could not be created
=> HADDOCK stopped


Make sure you have the correct definition of the path to the CNS executable.

Is your CNS executable working?

The path to the CNS executable is correct. Below you can see what is reported in the the file:
{===>} queue_1="/bin/csh";
{===>} cns_exe_1="/home/ubuntu/Desktop/Programs/CNS/cns_solve_1.3/intel-x86_64bit-linux/bin/cns";
{===>} cpunumber_1=4;

Also my CNS executable works. In fact when if I type in a new terminal /bin/csh and then /home/ubuntu/Desktop/Programs/CNS/cns_solve_1.3/intel-x86_64bit-linux/bin/cns I initiate the CNS software.


What is then the content of the begin directory in the created run?
Is it empty? Are there generate_X.out files present?

If this is the case, check at the end of those files for error messages.
If those are not present, then something is still wrong with your CNS definition.

Also try starting a fresh run.

In the run1/begin directory there are two generate_X.out files.
At the end of each file it is reported the following error:

%RTFRDR error encountered: exceeded MXRTRS (RTF) parameter --> recompile program
(CNS is in mode: SET ABORT=NORMal END)

ABORT mode will terminate program execution.

Program will stop immediately.

It seems that the error is due to CNS.

Did you recompile it with the provided files from the cns1.3 directory?

And otherwise I can share with you an executable - email me for that