Problem with the CNS executable

I have this error when trying to run local version of haddock
There is a problem with the CNS executable defined in run.cns:
./protocols/cns1: Command not found.

I followed all the cns download rules for haddock3 (from the link CNS Installation — haddock3 3.0.0 documentation) and when I typed in cns it gave the correct output

And I changed the file to my cns location in the file config.local
set CNSTMP=/home/software/cns/cns_solve-1.31-UU-Linux64bits.exe
set QUEUETMP=/bin/csh
set NUMJOB=4

what am I missing?
I made a new directory named sh3_qkc in the directory /home/qnt/drorimi2/software/haddock2.4-2023-01/
ran haddock2.4, then when in to the file run1 and wrote haddock2.4 and the error came up.

was I also supposed to change the location in the file run.cns? or do something else?
Thank you very much!

This does not seem a haddock3 issue, but rather a haddock2.X one.

Did you run the install.csh script after editing the config.local file?
And before doing that, remove if present the protocols/cns1 file

Try to copy your CNS executable directly to the protocols/ folder of your HADDOCK instalation

$ cp /home/software/cns/cns_solve-1.31-UU-Linux64bits.exe /home/qnt/drorimi2/software/haddock2.4-2023-01/protocols/cns1

thank you
now the error is
waiting for /home/qnt/drorimi2/software/haddock2.4-2023-01/sh3_qkc/run1/begin/sh3.pdb…
waiting for /home/qnt/drorimi2/software/haddock2.4-2023-01/sh3_qkc/run1/begin/sh3.psf…
waiting for /home/qnt/drorimi2/software/haddock2.4-2023-01/sh3_qkc/run1/begin/mc_qrppvppkpkwlc.psf…
waiting for /home/qnt/drorimi2/software/haddock2.4-2023-01/sh3_qkc/run1/begin/mc_qrppvppkpkwlc.pdb…
Error in the topology generation: prot_psf_mol1 could not be created


Could still be CNS-related.

Check the .out files in the begin directory for errors. Start at the bottom of those.
Did you first try to run a provided example?

when trying the protein-peptide example run I encountered the same error
waiting for /home/qnt/drorimi2/software/haddock2.4-2023-01/examples/protein-peptide/run1/begin/1NX1_protein.pdb…
waiting for /home/qnt/drorimi2/software/haddock2.4-2023-01/examples/protein-peptide/run1/begin/1NX1_protein.psf…
waiting for /home/qnt/drorimi2/software/haddock2.4-2023-01/examples/protein-peptide/run1/begin/DAIDALSSDFT_ext.psf…
waiting for /home/qnt/drorimi2/software/haddock2.4-2023-01/examples/protein-peptide/run1/begin/DAIDALSSDFT_ext.pdb…
Error in the topology generation: prot_psf_mol1 could not be created
=> HADDOCK stopped

the generate_1.out file ends like this
RTFRDR>set message=off echo=off end
%AUTOAN error encountered: exceeded MXRTT (RTF) parameter → recompile program
(CNS is in mode: SET ABORT=NORMal END)

ABORT mode will terminate program execution.

Program will stop immediately.

what does this mean?

You need to recompile CNS with the code provided together with HADDOCK (check the cns1.3 directory)

what I did to move the files of haddock cns to the cns source file was as followes:
cp /home/qnt/drorimi2/software/haddock2.4-2023-01/cns1.3/* source/
(and not what it said on the website since Im using haddock2.4 and not 3 so I cant do cp ~/software/haddock3/varia/cns1.3/* source/ since its not in the right directory)

is this incorrect? and thats why when I did the recompile it did not work properly?
thank you

And did you reinstall / recompile CNS after that? Was it successful?

Of course the exact commands of the tutorial can not be used as your installation directories are different

Thank you
it worked

1 Like