HADDOCK2.4 - Local installation - Exec format error

Hello everyone,

I would like your help with the following issue:

Traceback (most recent call last):
File “./tools/make_contacts.py”, line 86, in
_calculate_contacts(executable, struct, cutoff)
File “./tools/make_contacts.py”, line 32, in _calculate_contacts
p = Popen([executable, pdbfile, d_cutoff], stdout=PIPE)
File “/usr/lib/python2.7/subprocess.py”, line 394, in init
errread, errwrite)
File “/usr/lib/python2.7/subprocess.py”, line 1047, in _execute_child
raise child_exception
OSError: [Errno 8] Exec format error
foreach: No match.

Last time it continued until “Queue command failed, retrying in 960 seconds.” where I stopped the process.

My OS name: Ubuntu 20.04.4 LTS
My OS type: 64-bit
I have Python 2.7.18 (and Python 3.9.7) installed and added to the path.

I have followed the “HADDOCK2.4 local installation tutorial”. I have installed CNS, FreeSASA, HADDOCK-tools, PDB-tools, ProFit, PyMol and downloaded the “reduce” executable, all in the directory paths described in the tutorial. I am going to list some differences in my installation from the tutorial, in case I have done something wrong, missed any step or done something unnecessary:

  1. I did not find a “requirements.yml” file in the “haddock2.4” directory, therefore no conda enviroment was created based on it.

  2. The path for the CNS executable set for “CNSTMP” was set to “/home_path/cns_solve_1.3/intel-x86_64bit-linux/bin/cns” not “/home/software/cns/cns_solve-1.31-UU-Linux64bits.exe” (the same had to be done for the version of haddock3 where “/PATH/TO/cns_solve_1.3/intel-x86_64bit-linux/source/cns_solve-2002171359.exe” did not work for me), otherwise I could not make Haddock work. The same path I had to set for the “cns_exe_1” variable in the “run.cns” file.

  3. I did not find the following lines in the “Haddock/Main/QueueSubmit_concat.py” file:

I have tried “make clean” and “make all” in the haddock2.4 directory but it did not resolve the issue.

The initial process of creating the “run1” folder seems to work fine.

Try a “make clean” followed by “make” in the haddock installation directory

Could be some wrong executable has been left in the tools directory

The 2.5 version comes with requirements to setup a conda environment

Thank you for your quick response and providing this information to me. Unfortunately, the issue was not resolved with the “make clean” and “make” commands (in the haddock2.4 directory). The error message I get while running haddock2.4 in the run1 directory (based on the run.cns file) remains the same.

I should also note that during the installation process I get the following message:
Setting up QueueSubmit to QueueSubmit_concat.py
fatal: not a git repository (or any of the parent directories): .git
fatal: not a git repository (or any of the parent directories): .git

Is there any other information I can provide that maybe can help in resolving this issue?

Did you try with a fresh run1 directory and not the old one?

I had mistakenly used a path (for HADDOCK_DIR) in the “run.param” file for a previous installation I had performed for Haddock2.4 in another directory. When I selected the right directory and after I run the “make clean” and “make” commands there, Haddock2.4 run properly. Thank you very much for your time and help!