Error with Zn atom


I am trying to prepare a DSSB system with pmx doublebox (Github package), but I get an error with a Zn atom. I have tried saving the pdb in several ways but still get this error:

Traceback (most recent call last):
  File "/home/almeida/.local/bin/pmx", line 8, in <module>
  File "/home/almeida/.local/lib/python3.8/site-packages/pmx/scripts/", line 97, in entry_point
  File "/home/almeida/.local/lib/python3.8/site-packages/pmx/scripts/", line 44, in __init__
    getattr(self, args.command)()
  File "/home/almeida/.local/lib/python3.8/site-packages/pmx/scripts/", line 68, in doublebox
  File "/home/almeida/.local/lib/python3.8/site-packages/pmx/scripts/", line 72, in entry_point
  File "/home/almeida/.local/lib/python3.8/site-packages/pmx/scripts/", line 65, in main
    mout = double_box(m1=m1, m2=m2, r=args.r, d=args.d,
  File "/home/almeida/.local/lib/python3.8/site-packages/pmx/", line 1165, in double_box
    com1, rad1 = _get_com_radius(m1)
  File "/home/almeida/.local/lib/python3.8/site-packages/pmx/", line 1087, in _get_com_radius
    amass = _get_mass(a)
  File "/home/almeida/.local/lib/python3.8/site-packages/pmx/", line 1036, in _get_mass
KeyError: 'Z'

Any help will be appreciated.

Yes, I see that Zn could have been missed there. I now pushed a fix to the ‘develop’ branch

OK, thanks. I solved the problem by including the topology of the Zn ion manually in the general topology. I included the Zn entry in the aminoacids.rtp. Also, in the ions.itp file (in charmm36mut.ff) Zn has charge = -2 (bug?). I changed it to +2.


Indeed, it seems like some error in the ions.itp. Fixed it now. I recommend using the latest ‘develop’ branch though: there a newer charmm36m-mut version is provided (Zn error is not present there)