Error running

I am not sure this is the right place to ask, if not please let me know who I can ask.
I am trying to run a script that is used in HADDOCK papers (Information-Driven, Ensemble Flexible Peptide Docking Using HADDOCK) called “” in pymol and I am encountering the following error:

PyMOL>build_seq peptide, QGAADLESLGQ, phi=-60, psi=-40
Building sequence: QGAADLESLGQ
Error: Selection 0: Invalid selection name “_tmp_editor”.
( _tmp_editor and name N )<–
and only the first 4 amino acids are built.

I changed the code to work with Python 3 since I have a newer version of Pymol (changed the print and except syntax)
I’ll really appreciate your help.

It is a python version problem I am afraid…

Last time we used it on the nmrbox VMs and it worked fine.


I tried to convert the script to a python3-compatible version, it is working on my machine (pymol 2.5.5, macbook air M1), check it out (6.8 KB) and let me know if it works!

you’ll have to rename it to first


Thank you!
Unfortunately, it does not work on my laptop (Windows) Pymol version 2.5.5. It builds only part of the peptide.