Error: module name and a source file

In the need of Start HADDOCK in the directory where we saved the new.html file by typing

shows in terminal:
haddock2.2: command not found

after typing:
haddock 2.2
shows in terminal:
target ‘2.2’ is not a module name or a source file

Refer to:


Thanks a lot sir for replying…
Actually this error was resolved by entering into haddock 2.2 directory and copy new.html file in that and typing:
entered into c-shell and type:
source haddock_configure.csh
then its running
run1 directory has been created in which we have to edit run.cns file
But it gives error: waterdock false
Help me to resolve this!!waterdock_error

Now showing:

ln: failed to create symbolic link 'protocols/cns1': File exists
waterdock false
  waiting for the psf files...

Did you install CNS? Did you define its location correctly in run.cns?

Yes, but I don’t have ifort installed.

Now showing this error

No CNS = no docking!

Consider using our web server instead if you can not compile CNS…

yup…its compiled and docking runs…
But this error occurs:
Error in the topology generation: prot_psf_A could not be created

Something is wrong with your CNS installation. HADDOCK tries to launch the calculations and they fail. Have a look at the .out files in the begin/ directory of your run. What is the error message?

As @amjjbonvin said, maybe you should try using the web server, unless you are doing something really out of the ordinary.

Make sure to define the correct path in run.cns

Make sure that CNS is working

Start a fresh run (or remove protocols/cns1 and all *.out files in the begin dir)

First of all thanks for your concern.
Let me show you the generated A.out file in the /begin directory
%SETFPEPS increase value of MXFPEPS2 and recompile
%SETFPEPS error encountered: Could not determine machine epsilon
(CNS is in mode: SET ABORT=NORMal END)
ABORT mode will terminate program execution.
Program will stop immediately.
Maximum dynamic memory allocation: 0 bytes
Maximum dynamic memory overhead: 0 bytes
Program started at: \00\00\00\00\00\00\00\00 on \00\00\00\00\00\00\00\00\00\00\00
Program stopped at: 06:01:31 on 15-Dec-2017
CPU time used: 0.0040 seconds

Dear sir,
I surely define the correct path in run.cns
But I am not pretty sure about the working of CNS…
As .out files were generated in the begin directory, I think its working.

There you go. You need to look for the MSFPEPS2 variable in the CNS source code (grep the name on all .f files) and increase its value. Then you must recompile CNS.

Again, unless you are doing something extremely unique, use the webserver. It’s free and it just works.

Sorry, but I am not getting your point…
please explain step by step…

I am trying $grep MSFPEPS2 xyz.f
xyz->all .f files n source directory of CNSsolve
And also let me clear you why I am stuck with the software, because I want these results for further research and webserver’s results will be lost after 7 days and I was also tried web server, it’s too showing error

Error message

Status: Out of sync (in children)
  Invalid members: ['p2']
  Member p2 (Second molecule) :
    Out of sync (in children)
    Invalid members: ['r']
    Member r (Restraint definition) :
      Out of sync (invalid)
        HaddockValidationError: You manually defined passive residues, but also that they should be determined automatically


Despite the web servers results deleted after 7 days, the ensemble of the results, together with the summary page and the analysis that are done ONLY on the web server can be downloaded as a tar archive upon success of your run.

The error you report with the web server is, as it is stated, due to the fact that you input residue IDs in the passive field of the form for the 2nd molecule but you did not uncheck the option “Define passive residues automatically around the active residues” just below the list input. Try again with that and this should go true of no other error are present.

Really try first the server. Once you have a successful run (you are doing something wrong - not the server).

HaddockValidationError: You manually defined passive residues, but also that they should be determined automatically

Correct that error and try again. You can download all results and save them as long as you wish for on your computer.


  1. Did you check your CNS installation. Can you start CNS manually?

    For example, in my installation, I would have under tcsh to first source the cns_solve_env file:

    source /opt/nmr/cns_solve_1.31-UU/cns_solve_env

    Then I can type cns and if your installation is successful you then see something that should resemble:

           |                                                          |
           |            Crystallography & NMR System (CNS)            |
           |                         CNSsolve                         |
           |                                                          |
            Version: 1.3 at patch level U
            Status: Special UU release with Rg, paramagnetic
                    and Z-restraints (A. Bonvin, UU 2013)
            Written by: A.T.Brunger, P.D.Adams, G.M.Clore, W.L.DeLano,
                        P.Gros, R.W.Grosse-Kunstleve,J.-S.Jiang,J.M.Krahn,
                        J.Kuszewski, M.Nilges, N.S.Pannu, R.J.Read,
                        L.M.Rice, G.F.Schroeder, T.Simonson, G.L.Warren.
            Copyright (c) 1997-2010 Yale University
            Running on machine: Goodwine-3.local (Mac/Intel,64-bit)
            Program started by: abonvin
            Program started at: 07:57:44 on 15-Dec-2017



One this is working, you can then try running first one of the provided examples.

A protocol for running a local version of HADDOCK can be found in:

J.P.G.L.M Rodrigues, E. Karaca and A.M.J.J. Bonvin. Information-driven structural modelling of protein-protein interactions. Methods in Molecular Biology: Molecular Modelling of Proteins. Ed. Andreas Kokul. Humana Press Inc. 399-424 (2015).

And this forum is searchable - try first to look for answers. There are multiple threads about CNS problems, e.g.
1 Like