Active residue list


In October I did some docking using HADDOCK, and everything worked great. Recently, I wanted to redo some of the docks and do some new ones. Surprisingly, even with same input data I am having different results. The reason for that, is as following: I am selecting four residues as “active”, however even if I decrease the RSA limit to 5 and “Remove buried active residues from selection” is turned off, only one of them is then placed in jason config file in “activereslist” section. As result, in all clusters ligand is docked outside of the binding pocket. This one residue that is not removed from the list is most solvent accessible (what makes sense). When I did the docking in October I did not change any settings regarding RSA limits and docking worked fine - the ligand was placed right in the binding pocket close to those four “active” residues. I am using cryo-em structure and ligand present in this structure as control (I also do docking to single point mutants) so those residues I selective as active are 100% accessible and play key role i the binding, but now are removed from the active list. Were there any changes in HADDOCK algorithm since October? Are there any options I can change in order to restore solvent accessibility assessment rules to the ones were used previously?

Best regards!

Dear Michal

By default we now filter buried residues out because some users were defining all residues as active which was causing problems during the computation (waste of CPU resources and causing a long queue of jobs).

But this can be overruled provided you have expert or guru level access. What is your access level?
You mentioned you turned off the removal of buried residues.

And since October we had quite a few small additions / changes.
Also running the January 2021 release of HADDOCK2.4 as indicated on the server page: HADDOCK Web Server

Thanks for quick response!

So, I was turning off the removal of buried residues and have novice level:

"partners": {
    "1": {
        "activereslist": [
        "auto_his": false,
        "auto_passive": true,
        "auto_passive_radius": 6.5,
        "cg": false,
        "chain": "A",
        "charged_cter": false,
        "charged_nter": false,
        "cyclic": false,
        "dna": false,
        "filter_buried_active": false,

but the list of active residues was still reduced from four to one (number 200 in this case). But if I try replicate it now (different machine, different browser) I can’t do that anymore - I see a warning about the need of higher level.

So, I will apply for higher level of my account and will try this option.

We indeed corrected a feature of the server which now does not allow you to turn off that option unless you have the right access level (as you already found out).