Your HADDOCK run has failed

Hi Prof. Bonvin,

I am writing to you because since the last week jobs continuously fail in predict interface. I already checked the pdb file. It seems to look good. See below for error.

our HADDOCK run has encountered errors and was aborted. Go to for more details.
Note that HADDOCK results are deleted after one week.



We had last week issues with some grid sites on which our jobs are running.
The situation should be back to normal but this might have affected ongoing runs.
We did notify users about it.

When did you submit the last runs that failed?

I suggest you simply resubmit those.

Thanks Prof. Bonvin for your reply.

Yesterday, I have submitted. I submitted two jobs one with easy interface and finished. but, second was on prediction interface, that job was failed. I tried day before yesterday as well on prediction interface that on was also failed.


Ok - please try again and let us know if the prediction one now goes through

Hello Prof. Bonvin

Sorry, again job failed those I have submitted yesterday on Prediction interface. see the below detail.

Your HADDOCK run has encountered errors and was aborted. Go to for more details.
Note that HADDOCK results are deleted after one week.

Kind regards,

The HADDOCK server

Seems running fine now:

so far so good.

Dear Professor Bonvin,

I would like to ask why water refinement jobs submitted with “submit” option at HADDOCK2.4 web-server fail. I do not get any error message but I have noticed that number of both, structures_0 and structures_1, are set to 0 in job_params.json, although I was setting the values to 20.
The same structures submitted to Multi-body interface of HD2.2 or Refinement interface of HD2.4 are getting refined without any error.

Here are two links to the failed jobs:

Thank you very much.

The number of structures is indeed set to 0, which is strange.

Can you describe all the steps you did for the submission? Which parameter did you change…?

So that we can try to reproduce it.

PS: Are you following the following recipe?

Thank you very much for your reply.
Yes exactly, I am following the recipe exactly as described here:

I am setting the following parameters to 20, but after submission they are set to 0:
Number of structures for rigid body docking
Number of structures for semi-flexible refinement
Number of structures for the final refinement
Number of structures to analyze

I just tried to submit another molecule and the run failed again probably due to the same reason:

Well - I can not reproduce your problem. See:

BUT it indeed happens if following exactly the recipe:

  • Multiply the number of calculated structures by all combinations → True

If you leave it to false it works fine.

So a bug in the server machinery.

Thank you very much for your help.
I have restarted my jobs leaving the option to false and now it looks fine.

I am not sure what this option (Multiply the number of calculated structures by all combinations) exactly means, which structures will be multiplied. Can this option if it is left at false have a big influence on the resulting structures?
Do you think this bug can be fixed soon?

The option is meant if you provide an ensemble of starting structures - and it works if an ensemble is provided, but we have a bug if turned on for a single structure

Should be fixed soon

1 Like