Waiting for psf files

Dear BioExcel team,

We are new to protein protein docking and Haddock. We followed the haddock tutorials for the installation of the software. We are using only two pdb files. We generated the run file and initiated docking, but it is taking too long to generate the psf files. The program has been running for 4 days and it keeps displaying “Waiting for psf files”.

Since we are new to this, we are unsure of the time that it takes to generate the psf files. Is there any pointers that we can look into so as to speed up the process?

Also in the begin folder, the genreate_X.out file contains the message “runs_runX_generate_X.job: line 8: protocols/cns1: Is a directory”
Is there any steps that we did incorrectly?

Would really appreciate any inputs.

Thanks &Regards,

The generation of .psf files should be a matter of seconds only, there must be an issue somewhere.

My best guess would be that your CNS installation is not entirely functional.

Also, what version of HADDOCK are you using ? 2.4, 2.5 or 3.0 ?

In case you are not familiar with HADDOCK, I would suggest to start with the haddock2.4 webserver, which will spare you some trouble shooting of installing it (given it is for non-commercial use)

Thank you for your reply.

We are using haddock 2.5.
When we initiate CNS, we get the same result as given in this tutorial: CNS Installation — haddock3 3.0.0 documentation

Is there any cns executable file for ubuntu or can we use the windows .exe file itself?

Thanks &Regards,

Ok, that’s great !

A CNS executable is both Operating System (OS) and Hardware dependent. You need to compile one for the system you are working on.

Your issue may come from somewhere else.

I will try to figure it out and post a new answer asap

Be sure that the path protocols/cns1 is a copy of (or a link to) the CNS executable (and not to the installation directory of CNS)

When defining the CNS executable in run.cns point to the executable and not only the directory where it resides

Thank you.

Now we are getting a new error: “Error in the topology generation: prot_psf_mol1 could not be created”

Could you tell us what went wrong?

Thanks & Regards

Great ! One step at a time

Probably an issue with your PDB file that could not be properly understood.

Is it a standard protein with only natural amino acids? DNA/RNA ? Small molecule ?

Without the input file that you provided, it is difficult to judge.
Can you send it ?

Check the corresponding .out file in the begin directory.
Look at the end of it for error messages.

"%AUTOAN error encountered: exceeded MXRTT (RTF) parameter → recompile program
(CNS is in mode: SET ABORT=NORMal END)

ABORT mode will terminate program execution.

Program will stop immediately."
This is the error we are getting in the generate_X.out file.

1F0N-clean.pdb (333.8 KB)
3FZU-clean.pdb (513.4 KB)

These are the cleaned PDB files that we provided as input.

Thanks & Regards

Did you recompile CNS using the cns code provided with HADDOCK?

If not better do it.

We already patched cns with haddock custom files by following the tutorial present here:

But the same error is popping up. Is there anything that we should check on?

Thanks & Regards,

Did you try to run one of the examples?

We tried running protein-protein example but got the same error. Should we recompile CNS and try from beginning?

Thanks & Regards,

Best thing to try indeed

During the process of recompiling CNS, we encountered many errors, stating: “Type mismatch in argument”
The final message is as follows:
make[3]: Target ‘…/bin/cns_solve’ not remade because of errors.
make[2]: *** [Makefile:59: cns_solve] Error 2
make[1]: *** [Makefile:64: cns_solve] Error 2

Thanks & Regards,

We are using Haddock2.5 for our studies. But the instruction given for cns installation is for Haddock3.0. Are there any updates in the script files that execute cns within Haddock from v2.5 to v3.0 ? Since the error that is being generated is : “Type mismatch in argument”

Thanks & Regards,

CNS is the same between haddock versions

There is no different version of CNS for different haddock versions.

So the instructions are fine. The only change is the location of the directory where you will find the cns code provided with haddock.

Make sure that your CNS executable works.
And define it in run.cns (or the config file - redoing the configuration). What should be defined is the executable with full path (and not only the path to it)