ssDNA structure problem

Hello,

I am trying to simulate protein-ssDNA docking using HADDOCK. I first tried to predict the tertiary 3D structure of the DNA using aptamers master and then used it as input to HADDOCK. The simulated folded ssDNA input looks fine when viewed in PyMol, but when I started using it for docking in HADDOCK it resulted to a docked structure broken into multiple fragments.

When I viewed the xxx_1.pdb of the DNA under the “begin” folder, I noticed that the DNA fragments have already been broken at such an early stage of the docking run as pre-processing the input before docking. Tried to use the webserver and the results were the same, the DNA is fragmented even while visualizing the residues for AIR. I tried to investigate what happened in the input .pdb file and noticed that some Phosphorus atoms are now missing, particularly the ones involved in the nicks. I also tried tweaking some of dna restraints parameters (e.g. dihedral angle, base planarity) but it also got me nowhere.

Appreciate the help anyone could give. Thank you!!

Disconnected structure means something went wrong during topology generation. But if there’s something “wrong” with your input structure it should have been flagged by the webserver.

If possible, please send your input DNA to haddock.support@gmail.com so we can investigate.

Thank you for the quick response, I have sent an email with the .pdb files attached.

How did you build your DNA?

it should use proper base names for HADDOCK (see HADDOCK Web Server - Settings)
and have ATOM statements (and not HETATM).

I predicted the structure through aptamers master which takes in a DNA sequence as an input. It does have ATOM statements instead of HETATM, and upon comparing the pdb files side-by-side with the dna.pdb in the protein-dna example folder, I didn’t see any significant difference which might have caused such a problem.