Problems with CPORT webserver

Hi, I’m having issues using the CPORT server. The pdb file I am trying to input is an AlphaFold predicted structure of a heterotrimer (I am a new user so can’t upload the file as an example).

The error I get from the webserver is:
Traceback (most recent call last):
File “/home/enmr/services/CPORT/cgi/cport.py”, line 91, in
webform = cgi.FieldStorage()
File “/usr/lib64/python2.7/cgi.py”, line 507, in init
self.read_multi(environ, keep_blank_values, strict_parsing)
File “/usr/lib64/python2.7/cgi.py”, line 636, in read_multi
environ, keep_blank_values, strict_parsing)
File “/usr/lib64/python2.7/cgi.py”, line 509, in init
self.read_single()
File “/usr/lib64/python2.7/cgi.py”, line 646, in read_single
self.read_lines()
File “/usr/lib64/python2.7/cgi.py”, line 668, in read_lines
self.read_lines_to_outerboundary()
File “/usr/lib64/python2.7/cgi.py”, line 719, in read_lines_to_outerboundary
self.__write(odelim + line)
File “/usr/lib64/python2.7/cgi.py”, line 675, in __write
self.file = self.make_file(‘’)
File “/usr/lib64/python2.7/cgi.py”, line 767, in make_file
return tempfile.TemporaryFile(“w+b”)
File “/usr/lib64/python2.7/tempfile.py”, line 482, in TemporaryFile
dir = gettempdir()
File “/usr/lib64/python2.7/tempfile.py”, line 265, in gettempdir
tempdir = _get_default_tempdir()
File “/usr/lib64/python2.7/tempfile.py”, line 212, in _get_default_tempdir
(“No usable temporary directory found in %s” % dirlist))
IOError: [Errno 2] No usable temporary directory found in [‘/tmp’, ‘/var/tmp’, ‘/usr/tmp’, ‘/home/enmr/services/CPORT/cgi’]

I noticed a similar error on this forum from January of this year, the solution to this was to use pdb_tidy from the pdb-tools package. I tried this, and the same error persists.

I have also tried using the PDB file of the subunit from the AlphaFold Protein Structure Database:

This also didn’t work, even after also applying pdb_tidy.

The alignment file I’m using was created through CLUSTAL O (using UniProt Tools).

Would be grateful for any help, I am quite new to HADDOCK and CPORT.

Thanks for pointing out this issue

I’ve just re-submitted the structure you mentioned and it finished successfully: https://alcazar.science.uu.nl/serviceresults/CPORT/1759006/index.html

Could you please try again and let us know if its working? Could be an issue specific with the alignment.