Problem running gromacs simulation

I used your server to generate config files for gromacs md simulation with amber99sb* forcefield. I also wanted to upload and submit these files that your server generate in GRIDMARKETS gromacs. but their server encountered a problem that is: you’ll see from the log that your topology files includes a reference to a “ffamber99sbstar.itp” that wasn’t included in your submission

find attached the GROMACS force-fields included in MDWeb server, were you can find the ffamber99sbstar.itp file.
Please note that MDWeb is a very old platform (using GROMACS v4). I strongly recommend you to use new platforms such as BioBB, through the Jupyter Notebooks or the BioBB_Wfs Web interface (much similar to MDWeb).
Thanks for using our tools!
MDWeb_GMX_ffs.tgz.txt (2.3 MB)

Thank you for your response. I have a problem after running the job. It can’t clone the job. What should I do? Thanks

I also have a question. How can I run the project on my own computer with gromacs? I mean in your old website there was a option that you could download the configuration for gromacs setup with .itp .tpr and other formats needed.

Hi, we are trying to reproduce your problem with the project cloning, in our case is working fine. Can you tell us the project ID? And also why do you need to clone the project?

To run the production simulation with GROMACS in your computer, please take a look at the help pages:

You can actually also run the setup workflow in your computer:

Thank you for you response. I could clone it. I thought I should clone it for running with personal computer. Now you say that I dont need to clone the project.

also I dont get this in help section. In this case, the GROMACS portable binary file (tpr) needed for GROMACS to run a production MD has been generated. how should i generate tpr file?

and another question. The old server provided files with .tpr .top .gro and .mdp formats to run gromacs. Is there an option to do this with the new server?


the tpr file for the production run can be generated checking the corresponding option in the GROMACS setup workflow inputs:

the files you ask for will be then included in the output files to download:

All of these options are explained in the help pages.

Hope it helps!

Thank you very much for your continued support.

sorry for bothering you again. In the output file there is no .mdp file for gromacs setup. what should i do?

the server is generating the tpr for you so you don’t need the mdp file anymore, unless you want to generate your own tpr file. In this case, is up to you to generate your own mdp file with the desired gromacs parameters. You can start with the official gromacs mdp template and modify/extend it according to your needs.

Sorry for bothering you again. I have two problems. First, I don’t see any rmsf plot in the result analysis section. Does the analysis section provide us with rmsf plot? If not, how can I generate them? Second, I tried to do the md simulation for 100ns (100000ps) but after the completion of the project workflow the rmsd plot only showed 50ns. What is the problem?
Thanks in advance.


RMSf can be computed with the “Protein MD Analysis” workflow, take a look here: Help - BioExcel Building Blocks Workflows
You can also use the cpptraj_rmsf tool from the biobb_analysis module.

About the length of the simulation, it is difficult for me to figure out where the problem is, I would need more information, such as how did you run the production MD, with which program, with which input parameters, etc. I recommend you to carefully read the log files and try to understand why the simulation stopped at 50ns.

Thank you for your quick response. Unfortunately I deleted the project but I will try to rerun it and do as you said.

I tried to generate an RMSF plot from where you said. I used two files from the MD simulation result file that were generated by your server but after launching the project it stopped working. Would you please help me?
I attached the screenshots of error and files that I used as trajectory and topology. Are these files correct?


the protein analysis workflow is designed to work with a dehydrated trajectory. The files you selected are the correct ones, but you need to post-process them, removing counterions and water molecules before using them as input files for the Protein Analysis workflow.
This is the result of doing this process:

Thank you for your response. I didn’t quite get that. How can I remove ions and water for this process?


there’s many different ways to do this. You can use any tool available for that (vmd, cpptraj, pytraj, mdanalysis, mdtraj, etc.) or use our BioExcel Building Blocks. You have an example of trajectory post-processing in the Protein-MD setup workflow here: GROMACS Protein MD Setup tutorial - BioExcel Building Blocks

Hope it helps!

I ran a gromacs md simulation job with a total time of 100ns but the results showed only 50ns. What is the problem? Would you please help me? I attached the workflow log.
Thanks in advance.

workflow.pdf (139 KB)