I cannot reproduce a calculation from HAddock2.2 in Haddock 2.4


Last Feb 13th, I simulated a dimer using HADDOCK2.2. Last week, I tried to run a new calculation with different restraints, but the results I received was pretty strange: both monomers were 150 angstrom from each other, and no restraint was obeyed. I then tried to repeat the computation using the original restraints, and the same happened. I never got HADDOCK to reproduce the original homodimer, and all cluster I received had the monomers very far apart from each other. I believe I am doing something wrong, but I cannot figure out what.

The *json file I used last February can be downloaded from job_params.json - Google Drive

The JSON file generated now by the HADDOCK server is job_params (1).json - Google Drive

The only reelvant differences between rounds is that in Feb I did assign two active residues + restraints, and last week I only assigned restraints, But I thought that assigning active residues was not mandatory if obligatory restraints were described. Can you please help me solve this conundrum?

First of all probably a good idea to switch to using the 2.4 version of the server.

Second, most likely there is an error in your restraints definition and no atoms are selected.
Check carefully your restraints, residue numbers, segIDs, ….

The issue is that I used the exact same restraint file too :frowning: Every attempt to run it yielded monomers tens of angstrom apart. that’ s why I thought I might have stumbled into a rare kind of bug.

No bug - simply wrong restraints - or defined to non-existing residue numbers / atom names / chain IDs