Help Needed with Protein-Ligand Topology in pmx Tutorial


I’m seeking assistance.

I plan to process the protein and ligand to use them as input for the pmx tutorial. As mentioned in the following URL:

I have created topology using pdb2gmx and acpype+anteamber with the following commands:


  1. gmx pdb2gmx -f anony.pdb -o protein.pdb -ignh (choose amber99sb-star-ildn-mut.ff, number 1 (recommended water))


  1. Install acpype through conda: conda install -c conda-forge acpype
  2. acpype -i ligand_1.sdf
  3. Change the GMX.gro file in the ligand_1.acpype directory to GMX.pdb: gmx editconf -f ligand_1_GMX.gro -o A2A_11a_GMX.pdb
  4. Extract only the [atomtypes] section from the ligand_1_GMX.itp file to create the ffMOL.itp file, and the remaining characters constitute the MOL.itp file.

Q1: When calculating ligand topology using acpype+anteamber, is it not possible to specify a specific force field?

Q2: When running the pmx tutorial, before executing the genion command, I encounter the following error when running the grompp command:

“ERROR 1 [file merged.itp, line 10]: Atomtype n1 not found.”

Is this due to an issue with ligand topology, or could it be something else?

Q3: Please let me know if there are additional components or considerations I should be aware of in the ligand topology generation section.


Q1. When you write ‘a specific force field’, if you mean a class of force field, such as GAFF, CGenFF, OPLS, etc., then ‘No, you can’t specify those’. acpype+antechamber generates ligand force field parameters only for the variants GAFF (GAFF and GAFF2). You can read the various atom types you can specify using the ‘acpype -h’ flag.

Q2. The issue is in the ligand topology. The error means that an Atomtype ‘n1’ is specified in merged.itp file but it is not defined anywhere. It is generally defined in ‘ffmerged.itp’ file. You can trace back the error to ffMOL.itp and see if there was any mistake while copying the [atomtypes] section.

Q3. The protocol for ligand topology generations seems fine. I assume that you are following the same protocol for ligand_2 as well (steps 2-4 mentioned by you).


1 Like

I’m glad that the existing answers have been helpful.

However, the ongoing issue regarding the error is as follows:

“ERROR 1 [file merged.itp, line 10]: Atomtype n1 not found.”

After examining the atomtype.rtp file of various forcefields (amber14sb.ff, charmm36-jul2022.ff, amber99sb-star-ildn-mut.ff), it was confirmed that there is no atom named N1.

Instead, when looking at the multi-ligands.sdf file, docked with Glide, it contains an item called <s_lp_Force_Field> S-OPLS.

Q1. Can open-source force fields be applied in Schrödinger’s prep or docking processes?
Q2. I’m trying to add n1 to the .rtp file or create an atomname2type.n2t file through x2top, but it doesn’t work. I ran the following command. Is there another way?

gmx x2top -f lig_GMX.pdb -o -ff select

I was able to resolve the ‘atomtype not found’ error by going through the following process when splitting the .top file generated by acpype into MOL.itp and ffMOL.itp files.
However, I’m not entirely confident in the quality of this approach, and I believe optimization might be necessary.

  1. When entering [atomtypes] in ffMOL.itp, I manually changed ‘N1’ to ‘N’ in name and bond_type columns.
  2. When entering [atoms] in MOL.itp, I manually changed ‘N1’ to ‘N’ in type column.

Is manually making these changes a reliable approach?
Or is there another correct method that can be advised?

Good to know that you’ve been playing around with the topology files.

  • The error is because of an issue with the ligand topology files (merged.itp, ffmerged.itp; could be arising from MOL.itp, ffMOL.itp). So, it’s better not to tweak protein force field files (amber14sb.ff, charmm36-jul2022.ff, amber99sb-star-ildn-mut.ff).
  • Manually changing atomtype ‘N1’ to ‘N’ in MOL.itp and ffMOL.itp should be fine provided that an atomtype ‘N’ is not already present in these itp files. Be careful here.
  • Since your MOL.itp and ffMOL.itp files already contain atomtype ‘N1’ (as you mention), I wonder why is it not carried to ffmerged.itp (the error says that atomtype n1 is not defined). Could you please provide the sdf files for both of the ligands, so that I could reproduce the same error?