Haddock3 Doesn't Recognize clustrmsd Module After the Update

I recently updated the Haddock3 repository to incorporate the ilrmsdmatrix module for my ab-initio protein-protein docking. However, since the update, Haddock3 is no longer capable of recognizing the clustrmsd module when I run the command “haddock3 config_file.cfg.” I encounter the following error:
[2024-03-01 09:52:36,126 libutil ERROR] The following parameters do not match any expected parameters for module ‘clustrmsd’: ‘threshold’ did you mean ‘ncores’?.

Interestingly, when I run “haddock3-cfg -m clustrmsd,” it runs smoothly and is able to recognize the module.
criterion = ‘distance’ # $minchars 0 / $maxchars 100 / $title Criterion for fcluster / $short Criterion to be used to cut the dendrogram / $group analysis / $choices [‘distance’, ‘maxclust’]
linkage = ‘average’ # $minchars 0 / $maxchars 100 / $title Linkage type / $short How to lump together clusters in hierarchical clustering / $group analysis / $choices [‘average’, ‘centroid’, ‘complete’, ‘median’, ‘single’, ‘ward’, ‘weighted’]
min_population = 4 # $min 1 / $max 9999 / $title Clustering population threshold / $short Threshold employed to exclude clusters with less than this number of members. By default 4. / $group analysis
clust_cutoff = 7.5 # $min 1 / $max 9999 / $precision 3 / $title Clustering cutoff distance / $short Value of cutoff cophenetic distance. / $group analysis
n_clusters = 4 # $min 1 / $max 9999 / $title Number of clusters / $short Number of clusters to be formed / $group analysis

Thank you.

We have renamed some parameters to make them clearer…

In your case you need to replace threshold by min_population

Check the examples

1 Like