Find NOE violations

I see in your tutorial an explanation of how to find the NOE violations using print_noes.inp and ana_noe_viol.csh scripts (from Bonvin Lab). However, I was unable to run these scripts.
Maybe I am running them incorrectly- how should I?
I want to know which violations happen and by what distances.
I am using the local version haddock2.4
Thank you very much!

The simplest way is to run the full analysis in HADDOCK.

Change for that the runana parameter to full in run.cns

{======================= analysis and clustering ==========================}
{* Full or limited analysis of results? *}
{+ choice: "full" "cluster" "none" +}
{===>} runana=“full;

You can empty the analysis directory and restart haddock2.4

And if you want to do that for a specific cluster check the online manual at:


HADDOCK2.4 manual - Analysis

](HADDOCK2.4 manual - Analysis – Bonvin Lab)

Thank you
How can I do this if the docking is finished?
If I empty the analysis directory and do haddock2.4 (in directory with run.cns) then it will only fill the analysis directory without starting the docking over?

Yes - it will only perform the analysis

Thank you
I ran the analysis on only cluster 1 and this is how the beginning of the file looks

Rexp= 4.670 Rave= 10.991 Viol= -6.319 #viol= 165 ( A 63 LEU HG) ( B 16 TYR HE1)
Rexp= 4.380 Rave= 9.528 Viol= -5.143 #viol= 157 ( A 63 LEU HD12) ( B 16 TYR HE1)
Rexp= 5.480 Rave= 9.187 Viol= -3.705 #viol= 1 ( A 33 GLU HG2) ( B 13 ARG HH22)
Rexp= 5.080 Rave= 8.729 Viol= -3.649 #viol= 152 ( A 63 LEU HD21) ( B 16 TYR HE2)

How could this be? There aren’t 165 structures in cluster 1. (And when I analyze all structures the first #viol is 519 when I only have 200 structures.)

Thank you

Which file are you looking at?

And how many models are there in cluster 1?

114 structures


Try analysing the ambig and unambig files instead of all

Thank you
I looked and it is still higher

This is how I ran it:
cd /home/qnt/drorimi2/full_analize_40PDB/7pll/HADDOCK/run_flex_6_1/structures/it1/water/
$HADDOCKTOOLS/make_links.csh clust1
cd /home/qnt/drorimi2/full_analize_40PDB/7pll/ADDOCK/run_flex_6_1/

I also noticed that all the structures are in analysis_clust1

Check how many models are in the file.nam in the water dir.

After running the make_links.csh command it should in principle only contain the clust1 models.

file.nam should be a link to file.nam_clust1

Also important: Did you first run the ana_clusters.csh script in the water directory?

yes I did
attaching is my full script (first time in run.cns was analysed by “clusters”)


#Set up environment
cd /home/qnt/drorimi2/software/haddock2.4-2023-01/
source /home/qnt/drorimi2/anaconda3/etc/profile.d/conda.csh
conda activate /home/qnt/drorimi2/anaconda3/envs/haddock2.4
./install.csh config.local
source ./haddock_configure.csh

#Define pdb_name variable
set pdb_name = “7pll”

set filename = ( “run_7pll_HB_flex” )

#Loop through each filename
foreach arg ($filename)
echo 1
echo ${arg}
set haddock_dir = “/home/qnt/drorimi2/full_analize_40PDB/${pdb_name}/HADDOCK/${arg}”

#Navigate to directory
cd ${haddock_dir}/structures/it1/water/

# Clean up analysis directories
rm -f /home/qnt/drorimi2/full_analize_40PDB/${pdb_name}/HADDOCK/${arg}/structures/it1/water/analysis/*
rm -f /home/qnt/drorimi2/full_analize_40PDB/${pdb_name}/HADDOCK/${arg}/structures/it1/analysis/*
cd /home/qnt/drorimi2/full_analize_40PDB/${pdb_name}/HADDOCK/${arg}/structures/it1/water/

#Run full analysis
/home/qnt/drorimi2/full_analize_40PDB/7pll/HADDOCK/analyse_and_make_tbl/   #chamge to "full" analyse /home/qnt/drorimi2/full_analize_40PDB/${pdb_name}/HADDOCK/${arg}/run.cns
cd /home/qnt/drorimi2/full_analize_40PDB/${pdb_name}/HADDOCK/${arg}/
echo "Full analysis completed"

#Run analysis scripts
cd /home/qnt/drorimi2/full_analize_40PDB/${pdb_name}/HADDOCK/${arg}/structures/it1/water/
$HADDOCKTOOLS/ana_clusters.csh -best 4 analysis/cluster.out

#Run cluster1 analysis
cd /home/qnt/drorimi2/full_analize_40PDB/${pdb_name}/HADDOCK/${arg}/structures/it1/water/
$HADDOCKTOOLS/make_links.csh clust1
cd /home/qnt/drorimi2/full_analize_40PDB/${pdb_name}/HADDOCK/${arg}/
echo "Cluster 1 analysis completed"



the error is

wc: analysis/cluster.out: No such file or directory
foreach: No match.

I also tryed $HADDOCKTOOLS/ana_clusters.csh -best 4 analysis/cluster.out.gz and it didn’t work
it gets stuck on
starting analysis scripts for /home/qnt/drorimi2/full_analize_40PDB/7pll/HADDOCK/run_7pll_HB_flex_6_1/structures/it1/water
calculating average structure and similarity matrices
queue command:
waiting for the average structure…
/bin/tcsh HADDOCK_run_7pll_HB_flex_get_average.job

Thank you!

Do you see in the water dir cluster-specific file.nam_clustX files?

Also for the cluster ana script to work the cluster.out file in the analysis directory must be unzipped (i.e. not cluster.out.gz)

you might therefore add to your script a gunzip cluster.out command

Thank you!
Adding the gunzip command worked:)
Also, I couldn’t find anywhere a file where it says for a specific structure what the NOE violations are there, I only saw for a cluster/all. Is there a way?
Thank you,

The info is hidden in the .out files…

You could create clusters files containing only one model and repeat the analysis (a bit cumbersome…)