Error: elemental ion CA without specified charge

I am using Haddock to make a complex of RAP and LDLR (I am aware that there is an existing complex, however I want to see if I can dock these two together before I dock apoE to LDLR)

I get the error that my CA ions (I’ve got 8 in my file for LDLR (1N7D) are without specified charge so I defined them like this (I’ve also tried other LDLR files but those get the same error.):

HETATM 4822 CA CA A1008 21.696 63.631 -4.419 1.00124.70 CA

how I defined it:
HETATM 4822 CA+2 CA2 A1008 21.696 63.631 -4.419 1.00124.70 CA

However when I define the ions like this I get another error:
pdb file is incorrectly formatted. Please align the columns of your PDB properly.

I’ve tried to fix this by using the Protein Database File Editor instead of just fixing it in an txt file, but I still get this error.
I’ve also tried to remove the 8 CA atoms that I have but the same arror occurs

My supervisor suggested to compare this file to another file from last year that did work (4U7T) (it contained a Zn ion instead of CA), however the ions are defined the same way, so without any charge.

If anyone knows a solution that would make me really happy!

You must have shifted some columns in your PDB when editing it. Correct this.

You can try our PDB format checking tool available here:

It is named and detect most of the obvious errors that can sneak into a PDB file.

Thank you! I used the script to get the CA atoms out in the end and now my run is in the queue