CNS errors before/after recompilation


#21

Garima,
We need to see more of the compiler log to see what your error might be.


#22

After compiling CNS with make install and then source cns_solve_env after entering into C-shell tcsh
I was trying to run cns after typing cns
drriturajpurohit-CELSIUS-M740Bpower:~/Downloads/cns_solve_1.3> cns
Program will stop immediately.
============================================================
Maximum dynamic memory allocation: 0 bytes
Maximum dynamic memory overhead: 0 bytes
Program started at: on
Program stopped at: 08:12:32 on 16-Dec-2017
CPU time used: 0.0040 seconds
============================================================
drriturajpurohit-CELSIUS-M740Bpower:~/Downloads/cns_solve_1.3>


#23

Hello everyone,
I also got these errors and was able to resolve them.
Just take care of installation steps of CNS:
-> After registration, download xyz.tar.gz file “xyz = cns_solve downloaded version”
-> Enter the command in terminal: gunzip xyz.tar.gz
-> Then enter: tar xvf xyz.tar
-> This will create a new cns_solve directory. Now enter into this directory and copy the path.
-> Now open the file cns_solve_env and paste the copied path in place of ‘location of CNSsolve directory’
-> Then open the terminal in this directory, and enter the command:tcsh
-> Then you entered into C-shell, now enter the command: source cns_solve_env
->Then enter: cns
-> Your software will definitely run without any error.


#24

Dear Dr. Bonvin,

I am having the same problem with CNS installation, but I cannot figure out how should I remove -fast-math flag. In my Makefile I don’t have such flag. I tried to run make no-fastm after make clean but it looks like compilation still runs with fortran -ffast-math option.

Thank you


#25

Depending on your operating system, when installing CNS a directory specific for your OS will be created, e.g. intel-x86_64bit-linux/source on a Linux 64bits system.

Go into that directory and edit the Makefile script.

Then in that dir try: make cns_solve


#26

Thank you very much! I think it’s fine now