The number of partitions (ncvpart) for random removal of restraints must be an integer!

Hello,

Job number 247887

I am trying to submit a job to the HADDOCK 2.4 server, I am able to submit the job but within a few seconds of running the job fails with a topology generation error. I am unsure how to fix this issue, any help would be greatly appreciated.
job_params.json (192.3 KB)

Regards,
Dan.

Dear Dan

Did you turn on the bioinformatics settings?

If this is the case there seems to be an issue on our side.

Dear @amjjbonvin

I don’t think I specifically turned on the bioinformatics settings.

But I am using the same settings as outlined in the “Settings for running with bioinformatic predictions” i.e. * Number of partitions for random exclusion1.1428 etc.

Thank you,

Regards
Dan.

Thanks for reaching out with this issue @dhall1 .

Looking at the log we can see that:

# ...

parsing run.cns file
The number of partitions (ncvpart) for random removal of restraints must be an integer!
=> HADDOCK stopped

# ...

The error message is clear, but the reason why this is triggering not so much.

The source code of HADDOCK cannot handle Number of partitions for random exclusion (ncvpart) different from an integer.

However, in the web interface when you use a float, such as 1.1428, there is a backend function that will generate a specific subset of restraints for each model that will be generated during HADDOCK execution.

By doing that you are effectively removing the effect of the Random removal of restraints (noecv), since each model will have its own restraint, hence no removal is needed.

If you are using the submission interface and change the Number of partitions for random exclusion (ncvpart) to a floating point, the Random removal of restraints (noecv) is automatically turned off behind the scenes.

In your particular run it seems that Random removal of restraints (noecv) is set to True even with Number of partitions for random exclusion (ncvpart) not being an integer.

This should not be the case, could you please indicate the steps you took to setup this simulation?

Thanks!

Hello @honoratorv

Thank you for your response.

This is the list of steps to reproduce the error I am experiencing.

1) Give a job name, and select two molecules. Upload molecule 1 (a nucleic acid) generated in AMBER and upload molecule 2 (a post-translationally modified metalloprotein) selecting nucleic acid and protein respectively for the kind of molecule I am submitting.

2) Given this is ab initio docking I am not selecting any active/passive residues for either molecule or selecting any semi/fully flexible segments. But I do check the Hisitdine protonation states which are correct.

3) I leave whatever the optimal run settings are for nucleic acids.

Create DNA/RNA restraints: Ticked
Remove non-polar Hydrogens: Ticked
Define randomly ambiguous interaction restraints from accessible surface residues: Ticked

Center of mass restraints/Surface contact restraints? Nothing ticked

Random Exclusion
Randomly exclude a fraction of the ambiguous restraints (AIRs): Ticked
Number of partitions for random exclusion (%excluded=100/number of partitions) = 1.1428

Radius of Gyration restraints: Not ticked/default value

Sampling Parameters
Values used in the bioinformatics prediction e.g. rigid body minimization =1
number of structures to analyze = 400 etc

I hope this helps :slight_smile:
Regards,
Dan.

Thanks, the description was extremely useful.

I’ve managed to locate and patch the issue, could you please try again and let us know if everything is working fine? :mechanic:t4:

Hello,

Everything is working as intended! :slight_smile:

Thanks once again

Regards,
Dan.

1 Like

Amazing! Please let us know if you ever run into other issues. :cowboy_hat_face: