Local PRODIGY installation trouble


#1

Hello,
I was just trying to get a local PRODIGY install running, and although I think I have everything in place (I cloned the PRODIGY git repository and followed the instructions in the readme to install everything else), I’m getting a missing module error when trying to run predict_IC.py (see following message). I’m missing “aa_properties” so clearly something’s not where it needs to be, but I don’t know where “aa_properties” is supposed to come from.

My config.py paths look like this:
FREESASA_BIN = “/usr/local/bin/freesasa”
FREESASA_PAR = “/Users/ME/freesasa-2.0.3/share/protor.config”

Thanks,
Matt


predict_IC.py error message:

Traceback (most recent call last):
File “predict_IC.py”, line 32, in
from lib.freesasa import execute_freesasa
File “/Users/ME/prodigy/lib/freesasa.py”, line 27, in
from aa_properties import rel_asa
ModuleNotFoundError: No module named ‘aa_properties’


#2

you could try to use the new package implementation by installing prodigy directly from the respective branch with pip:
pip install git+git://github.com/haddocking/prodigy@python3_package
(In this case the environment variables “FREESASA_BIN” and “FREESASA_PAR” should not be set to use the freesasa python package)
Note: if you are using python 3, your biopython version should be >=1.71 as in older versions a bug causes the results to be incorrect. Ideally you might validate a local test run with the results provided by the server.


#4

Dear Matt,

A good solution is indeed what Joerg suggested to you, by using the new package.

If you don’t manage that, please notice that the tow freesasa path should look like something like this:

FREESASA_BIN = “XXXX/freesasa/bin/freesasa”
FREESASA_PAR = “XXXX/freesasa/share/freesasa/naccess.config”

I hope this can help.

Best regards,
Anna


#5

Hi all,

Thanks for the suggestions! Joerg’s installation suggestion worked perfectly for me.